Site Token Revoke Procedure

Issue

When Order Entry is installed on a server, there may be an issue where it does not display within ECM's Worldview despite all services running.

Causes

  • Pre-existing Order Entry server build was not uninstalled correctly

  • Installation of live SiteID onto a new server - 2 live sites installed into production

  • Installing new SiteID over existing Order Entry software. 

Steps to remedy 

  1. Log in to ECM and verify the status of the server in Worldview. 


    • After installation and verification of OE services on the server, all three sections in Worldview should be green check marks.

    • Good: Your site is good!

  1.  

    • Bad: Continue to step 2




  2. Click the pencil and edit the site


  3. Navigate to the Listener section. Click Revoke under Revoke Token

    1. After you revoke it, the section that says TOKEN will say NULL


  4. Log in to OE Server


    1. Click RUN and type CMD to open Command Prompt

    2. Type REGEDIT - This opens up Windows Registry Editor window so you may navigate to the token





      1. Click on HKEY_LOCAL_MACHINE

      2. Click on SOFTWARE

      3. Click on Custom Business Solutions

      4. Click on Northstar Order Entry

      5. This is the Token that will be renewed


    3. Delete the Token

    4. Type SERVICES.MSC in Command Prompt

    5. Restart Northstar Listener service

    6. Refresh the Windows Registry Editor window and a new Token will be recieved

    7. Wait a few minutes before checking Worldview



  5. Finished.