Site Token Revoke Procedure
Issue
When Order Entry is installed on a server, there may be an issue where it does not display within ECM's Worldview despite all services running.
Causes
- Pre-existing Order Entry server build was not uninstalled correctly
- Installation of live SiteID onto a new server - 2 live sites installed into production
- Installing new SiteID over existing Order Entry software.
Steps to remedy
- Log in to ECM and verify the status of the server in Worldview.
- After installation and verification of OE services on the server, all three sections in Worldview should be green check marks.
- Good: Your site is good!
- Bad: Continue to step 2
- Bad: Continue to step 2
- Click the pencil and edit the site
- Navigate to the Listener section. Click Revoke under Revoke Token
- After you revoke it, the section that says TOKEN will say NULL
- Log in to OE Server
- Click RUN and type CMD to open Command Prompt
- Type REGEDIT - This opens up Windows Registry Editor window so you may navigate to the token
- Click on HKEY_LOCAL_MACHINE
- Click on SOFTWARE
- Click on Custom Business Solutions
- Click on Northstar Order Entry
- This is the Token that will be renewed
- Delete the Token
- Type SERVICES.MSC in Command Prompt
- Restart Northstar Listener service
- Refresh the Windows Registry Editor window and a new Token will be recieved
- Wait a few minutes before checking Worldview
- Finished.