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POSiGuestPay – 6.41 and up – feature priced via POSiPortal subscription 
175-Allow POSiGuestPay 

Setup>User Privilege Codes>assign Privileges: “175 – Allow POSiGuestPay” allow/disallow 
POSiGuestPay from being accessed by user. 
 
 

 
 

  



For each terminal “POSiGuestPay” and “POSiGuestPay Only” 

 Setup>Hardware>Terminal Stations>Edit: “POSiGuestPay” Needs to be turned on in order to use 
this new feature and “POSiGuestPay Only” Allows the terminal to be set to POSiGuestPay only.  
No checks can be opened; no POSitouch functions other than payment can be performed on 
designate terminal. 

 
 

  
  



 
POSiGuest Pay allows guests to pay their check at the table using any credit card. 

 

 

With POSiGuest Pay, guests can pay multiple checks split checks; enter gratuities by percentage or 

amount of choice,  

 

 



They can then print or email their receipt. 

 

  



Then the signature, the email address and the closed check xml are sucked up to PosiPortal and then 
PosiPortal makes a pdf receipt and emails it. 
 

 

 

 

 

 

 



POSiPortal 
 
POSiPortal is a suite of cloud-based “above-store” applications connected to POSiTouch.  Flash Reports 
is a small set of reports covering the key measures needed to monitor and manage a store or group of 
stores.  Information is presented as a cross-section of stores in real-time and can be accessed on any 
device with an internet connection and a browser.  
The POSiPortal system has two different interfaces for accessing information.  One is accessible via your 
PC or laptop using a web browser.  This is referred to as POSiPortal.   
 
The other is accessible via the browser utilized by your mobile device – smartphone, tablet, etc.  This is 
referred to as POSiMobile. 
 
Exceptions 

Exception conditions such as overtime, break violations, minors, too much cash in drawer can be emailed 
or texted in real time to managers, owners and headquarters. 
Exceptions can be reviewed later on mobile or desktop devices by store, date and exception type. 
 

 
 
  



Flash Reports - Monitor Your Stores’ Sales and Labor Activities  

1. Select stores from the store hierarchy panel on the left, select a business date and a report in the 
selection criteria panel in the middle and view the data in the workspace panel on the right.    
2. Drill down into more detail by pressing the “expand” (+) control in a grid row.    
3. Open a PDF version of a specific store’s report by pressing the PDF icon in the store’s header.  
 

   
 
 

 

  



Time Report 

The time report allows management to drill down to the specific employee and the hours worked for a 
given day. 

 

  



QMEConnect 

 
QMEConnect is a facility for distributing menu changes done in QM Enterprise.   Menu updates are 
created at corporate headquarters, automatically uploaded to POSiPortal and distributed to stores either 
automatically or on a schedule.   The QMEConnect Dashboard allows the chain customer to monitor the 
progress of the distribution of menu updates. 
 
 

 

 
 

 
  



Dealer Dashboard 

 

The Dealer Dashboard allows dealers to monitor the health of sites via POSiPortal.   It displays the 

Spcwin version, QM version and various other information about the site.   It shows the health of the 

POSiPortal agent connection to POSiPortal and can alert about sites not properly connected to PP. 

 

 

POSiPortal Licenses 
POSiPortal licenses will replace hardware security keys in the future.  Sites will install the POSiPortal 

agent and its connection to POSiPortal will update licensing information.   This will facilitate the provision 

of POSitouch systems on a rental basis as it will give full immediate control over licensing. 

  



Allow Male/Female Seats 

Setup>Restaurant Miscellaneous Data>Seats and Separate Checks: “Allow Male/Female Seats?” 
 

 
 
 
  



Snapshot checks look like regular checks 

Setup>Restaurant Miscellaneous Data>Guest Checks 1>Snap shot checks look like regular checks: 
Changed flag that used to say “Eliminate do not pay msg from snapshot checks?”  This is what people 
really want. 
 

 
 
  



Credit Card enhancements 

 
CC Auth makes cell type 6 taxable 

Setup>Tax Rates>Tax Rate>”CC-auth makes cell type 6 taxable?” 
This is a new feature that will allow bars to turn tax included into tax added when paying by credit 
card.   Pay by cash and 4 beers are $10, pay by credit and they are $10.70 with 7% tax. 
 

 
 

 
 
Require CVV on manual transactions 

Setup->Credit Cards->Merchant Data->More 3:”Require CVV on manual Transaction?” 
Also moved “Require CVV on swiped Transaction?” and changed labels from CID to CVV. 
 
 

 



 
 

Gift Card Inquiry Notice via External Device 

Setup>Credit Cards>Merchant Data> More Fields: “Send Gift Card Inquiry Notice to External Device?” 
 

 
 
 
Eliminate CR between magnetic card tracks 

Setup>Restaurant Miscellaneous Data>System 1>More: “Eliminate CR between magnetic card tracks?” 
There are terminals that send in track data in different ways if you don’t use OPOS.   This deals with a 
common variant that POSi doesn’t like where there are CR’s between tracks. 
 
 

 
  



New KVDU features 
Improving logic for line item bumping on Variable format vdu’s 
Bumped Items disappear 

Setup>Hardware>Kitchen Videos>Edit:” “Bumped items disappear”  
 

 
 
New Flag to allow Expedite cell 17 to change window color but not move it to the head of the 
queue 

Setup>Restaurant Miscellaneous Data>Table and KVDU Status: “Expedite Cell 17 highlights only?” 
 

 
  



Master Bump checks prep sequence 

Setup>Restaurant>Miscellaneous Data>Order Screens>Fast Food 2: “Master Bump checks Prep 

Sequence?” goes hand in hand with the flag above it that states “each send is a new window”.  These 
flag settings check for different prep sequences or different times on the same order before allowing the 
“master” bumper to bump the entire order.  meaning, I can place my entire order,  apps, salads, 
entrees, all at the same time but with the flag below they will go into their own “window” on a kvdu so 
they look like separate orders, so they need  “Master bump checks prep sequences”  to determine that 
they should not be all bumped at the same time. 
 

 
 
 
 
 
  



Second overdue time increased 

Setup>Hardware>VDU colors>Overdue selection screen:”2nd overdue Add time” 
We increased the number of digits for the 2

nd
 overdue time for kvdu’s.  We now support 4 digits. 

So the range has changed to 0 – 9999. 
 

 
 
  



Account on Vdu and Expo slip 

Account Name on VDU 

Account Prep fields on expo slip 

Setup>Restaurant Miscellaneous Data>Order Screens/Fast Food 2: “Add account name to VDU?” and 
“Add account prep fields to Expo slip?” 
 

  
 
 
 
  



No on the Fly VDU by Defined Menu 

Menu Screen> Defined Menu>”No on the fly VDU?” We have added a new flag for each Defined Menu: 
“No On the Fly VDU?” So you can decide by defined menu which if on the fly orders go to the Kitchen 
video. 
 
 

 
  



Support for “Epson TM-P20 and P60 printers”. 

 

 
 
Allows extra logos to print, using Guest Check Headings, for P20 and P60 printers 

 

Epson P20 Logos  

 

Needed Epson Utilities 

 

The Epson P20 and P60 printers print logos differently than all the Epson printers that we currently 
support. 
Prior to these machines, all we did for logos was create a new LOGO.T85 file, and download it to the 
printer, to store the logo. 
Now, with the P20, and the P60, the only way to get a logo stored on the printer is thru the Epson TM-
P20 Utility 1.0 program.  There is also a utility for the P60 but it is called FlashLogo.  It works about 
the same, so I will only discuss how to download to the P20 printer. 
 
These printers work using IP WiFi so you will need to use the EpsonNet Config V4.5.3 to configure 
the printer first, so you will have access to it via WiFi, before you can use the logo download. 
 
The topic of using EpsonNet to configure your printer for WiFi is beyond the scope of this document. 
 

Using the Utility to Download Logos  

 
When you first run the Epson utility, you see this screen. 
 



  
 
 
 

From here, you click Add Port to find your P20 printer.  You should have already gotten your P20 
printer connected to your network, and can ping it using the ping utility. 
Click Add Port and you will see this screen. 

 
 

 
 
 
  



Change the IP Address to match the IP Address that you sent your printer to, and click search. 
It will find your printer and the screen will look like this, with the found printer inside the window.  
 

 
 
 

  



Highlight the IP Address inside the window, and click OK. 
 

Another way to connect to the printer, you can use a USB cable, but plugging in the printer into 
the USB cable, and into your PC. 
In that way, just click USB, and wait for it to show the printer in the pulldown window.  Once the 
printer appears, then clicks OK to change the printer settings. 

 
You will see this screen, once it connects to the printer. 

 
 

Click Storing Logos to go to the logo screen. 
It will show you any stored logos and the key codes used, with those logos. 

  
 

You will need to delete any stored logos on the printer, to refresh with new logos, if needed. 
Highlight any logos and click Delete button. 
Once you have removed any logos, you are now ready to add them to the printer. 
Click Add to add a logo. 
You will be prompted to select the logo from your directory on your hard drive.  Find the correct 
log, and click Open. 
Your logo should really be in monochrome format, but, if it is not, the software will give you 
options to try and convert it to monochrome and show you the results. 
This screens shows you how it will look in the right pane, so you can use the controls available on 
this screen, to adjust the logo until it fits your needs. 
 



 
 
Once it appears how you like it, click OK. 

It will pop up a window, asking what keycode.  SPCWIN will always use the logo stored for 
KeyCode 00 so enter 48 in both windows, and click OK. 
You will then see this screen, which shows that it’s been processed.  You need to highlight the 
row, and click Store to Printer, to actually send the logo to the printer’s storage area, for SPCWIN 
to be able to print it. 
 

 
 
  



Once you have completed downloading it to the printer, you will be shown this screen, to let you 
know it is now stored in the printer. 

 

 
 
At this point, you have completed downloading logos to the printer.  The next step would be to 
use spcwin to configure this printer and use it to print from.  Keep in mind, in order to be able to 
see and print the logo, a printer reset, from the status screen, or reset a device screen must take 
place, before any printing to this new setup. 
If you need to also print other logos on this printer, you can download additional logos to the 
printer, and use the next available keycode.  I.e., Main logo is at 48,48, and the next logo would 
be at 48,49, then the next one, after that, would be at 48,50. 
Using extra logos in spcwin is beyond the scope of this document, but look into Guest Check 
Headings using code ~@Lx where x is which logo, 1, 2, 3, etc.  Logo 1 would be the logo located 
at 48,49 and logo 2 would be the logo located at 48,50, etc. 
 

 
 
 
 
 
  



Remove server check number from guest check heading 

Setup>Restaurant Miscellaneous Data>Gust Checks: Eliminate SvrChk from Check?” This is a new flag 
to remove Server check number field from guest check header.  Customers were confusing this with the 
actual check number when filling in survey information. 
 

 
 
  



No Paging - by Terminal 

Setup>Hardware>Terminal Stations “No Paging”. This is a new setting in hardware terminals, which 
controls the availability of the Paging button by terminal. 
 
 

 
 
 
 
XML Ordering Enhancements 
Allow appending loyalty cards to cslots via xml with new tag <LoyaltyCard>  
 
Loyalty Card Example 

 

<CreditCardAuth>  

   <CardNumber>6036283265658666746 
                      </CardNumber> 

Gift and Loyalty cards can be submitted 
unmasked.  

   <ExpirationDate>XXXX</ExpirationDate> Expiration dates are not used 

   <LoyaltyCard>Y</LoyaltyCard> Marks the card to be added to the check 
as a loyalty card. When the card is setup 
as a gift/loyalty card, by default the 
system will add the card to the check as 
a gift card. This option forces the system 
to add the card to the check as a loyalty 
card.  

   <ReferenceNumber>070101881000219 
                    </ReferenceNumber> 

 

   <ApprovalCode>804718</ApprovalCode>  

   <Amount>0.00</Amount>  

  </CreditCardAuth>  
 



Line item comps with specified <SerialNumber> of item to attach to 

Line Item Comps 

 
Line item comps may be applied to particular items. The following example from within an XML order 
shows the <CompItem> tag: 

<ItemDetail> 
<ItemNumber>111</ItemNumber> 

</ItemDetail> 
<CompItem> 

<ItemNumber>234</ItemNumber> 
<CompSerialNumber>123</CompSerialNumber> 

</CompItem> 
 
In this example, the item number 234, has been configured in the POSitouch database as a Cell Type 1, 
with the “COMP” option active. The <CompSerialNumber> is obtained by placing an 
<OpenCheckRequest> to the POS system. The output file from the POS system will contain the items on 
the check, as well as the <SerialNumber> for each item. The serial number is then fed back to the POS in 
the <CompSerialNumber> field.  If not properly configured or the referenced item cannot be found on the 
check or is deleted, errors will result. 
 

 
 
 
Deletion of Comps, Coupons and Cell type 12 discounts with specified <SerialNumber> of the item 
to delete 

Deleting Items 

 
The system allows items that have reduced the check amount, to be deleted. These include items as: 

 Comps 

 Coupons 

 Cell Type 12 Discounts 
The item to be removed from the check is referenced by the Serial Number. The <DeletionSerialNumber> 
is obtained by placing an <OpenCheckRequest> to the POS system. The output file from the POS system 
will contain the items on the check, as well as the <SerialNumber> for each item. The serial number is 
then fed back to the POS in the <DeletionSerialNumber> field.   
A sample XML is: 

<ItemDetail> 
<ItemNumber>111</ItemNumber> 

</ItemDetail> 
….. 
<DeleteDiscount> 



<DeletionSerialNumber>123</DeletionSerialNumber> 
</DeleteDiscount> 

 
This example would remove the discount, with serial number 123, from the check.  
 
 
Open Dollar Discount – additional approach – new tag <OpenDollarAmount> 

Open Dollar Discount 

The system allows for submission of an open dollar discount via the <OpenDollarDiscItem> block. 
Applying an item requires that the item  

1. be a cell type 12; 
2. have a price of zero (0.00) in price 1; 
3. Open Dollar is set to active; 
4. with a multiplier, cell type 3 as the only option.  

 
A sample XML includes:  

<ItemDetail> 
<ItemNumber>111</ItemNumber> 

</ItemDetail> 
…. 
<OpenDollarDiscItem> 

<ItemNumber>234</ItemNumber> 
<OpenDollarDiscAmt>-10.00</OpenDollarDiscAmt> 

</OpenDollarDiscItem> 
 

 
 

Open Percent Discount – new tag for percentage <OpenPercentageAmount> 

Open Percent Discount 

The system allows for an open percent discount, in addition to the open dollar discount.  The following 
options must be set: 



1. be a cell type 12; 
2. have a price of zero (0.00) in price 1; 
3. with a multiplier, cell type 3 as the only option. 

 
A sample XML is: 

<ItemDetail> 
<ItemNumber>111</ItemNumber> 

</ItemDetail> 
…. 
<OpenPercentDiscItem> 

<ItemNumber>234</ItemNumber> 
<OpenPerecentDiscPct>-10.00</OpenPercentDiscPct> 

</OpenPercentDiscItem> 
 

 
 
Additional place order options 

Ability to place orders via: 

a. Additional options that insure that the correct instance of an item that may appear on 
multiple screens are as follows: 

Item, screen 

<ItemScreen>111,30</ItemScreen> - selects the item but only if found on the indicated screen. 
 
Item, menu 
 

<ItemMenu>111,5</ItemMenu> - selects the item but only if found on a screen that is part of the 
designated Menu. 
 
Item, prep cat 
 

<ItemPrepCat>111,4</ItemPrepCat> - selects the item but only if it’s Prep Category matches the 
indicated prep category. 



XMLTransfer Check 
Setup<\>Restaurant Miscellaneous Data>XML I/O Setup: “XMl Transfer Check Printer” 

 

 
 

  



XML Notify for servers 

Setup>User Privilege Codes>Assign Privileges: “174 – Message for XML Checks” New tag 
<NotifyServer> that adds a record to the slot of these notifications 

 

 
 

 
 
 

 
 



Custom Guest Check Text via XML File Submission - memo on check header/trailer.  

 
Users may wish to submit a custom memo line to the check by using an XML file. For example, if 
the following were to appear on a guest check: 

 
If you wish to review  
Your check on your  
Mobile phone open  
Your app and key in the 
Following code: 

        H3r5g7 
       Thank you 
 

A Memo Line is one or more text lines that will get added to the printed output.  If you want these 
lines to be centered on the output you will have to prepend the lines with blank spaces in front of 
the text. 
Each line of text can be single wide or double wide by prepending the text with D or S character. 
 

 Each memo line must contain a “^S” or “^D” for single or double width printing. See additional 
details below.  

 A memo line cannot exceed 24 characters in length 
 
 
  



How to.. 
The requirements for this particular option include adding menu items. Users may add menu 
items via Menu Editor > Edit an Order Screen > and choosing a screen then an empty cell. 

 
A cell type 9, Memo, must be programmed into the menu system 

Set the Option Routing to With Main Item (thus not routed) 
Do not activate the option “Exclude From Check” 

 

 
 
Choose MORE FIELDS and set the EXCLUDE FROM ONSCREEN GUEST CHECK 

 

 
 
  



A cell type 7 menu item, Main Item, not taxed. 
Create the menu item to be used for the Memo.  
Set the price to zero; 
Prep Category set to NONE REQUIRED 
Set the option, “Exclude from check” 
Add the Memo item (1994, from step 1) to the Main Item (1997) 

 

 
 

  



In Guest Check Headings, shown above, enter the following: 
~^MEMO when wanting Memo Lines printed 
Do not include a file name or any additional characters 
Be sure to set the Cost Centers, also. 

 

 
  



The XML file submission containing the Memo Lines, should include the Memo main item 
followed by a memo entry starting with the “^S” or “^D” characters in order to set single width 
or double width. In the example below, the main item 1997 is ordered, and will be excluded 
from prep slips and printed guest checks. The on-screen guest checks will show the main 
item and the memos. Item 1994 is the cell type 9 attached to the 1997 main item.   

 
In the example XML excerpt, the main item memo is highlighted, followed by the Memos.  

 

 
 

 
  



Memo lines cannot exceed 24 characters in the XML file. However, multiple memos in 
the xml file are concatenated. In the example above, if the customer code and the “Thank 
you” memo lines were to be on the same line of the guest check, the XML entry would 
appear as: 
 

<ItemDetail> 
     <ItemNumber>1994</ItemNumber> 
     <Memo>^SFollowing code:</Memo> 

</ItemDetail> 
<ItemDetail> 

     <ItemNumber>1994</ItemNumber> 
     <Memo>^H3r5g7|</Memo> 

</ItemDetail> 
 

The single and double character markers (^S and ^D) should only be used when starting a new 
guest check line, following a pipe character (“|”).  

Using the above example, notice the “^Sfollowing code: “ line has no pipe character, and 

the second line that is concatenated, does not begin with the single nor double marker (^S nor 

^D) – but does begin with a ^.  

New Xml Ordering Functions 

We have added two functions to the list of things that are possible with xml ordering without security key 
bits: 

CancelOrder 

UpdateOrder  

This is where the only thing done is to change the table number, i.e. a transfer of a check from one table 
to another.    We created a new tag <NewTable> and if an order has a check number and this tag, it is ok 

without the key.   Nothing else in the order. 

 
Compare to number in Party - Additions 

 

                 



Disable Additional compare items by defined menu 

Menu Screens>Define Menus>Options: “No additional compare items?” This allows separation of 
additional compare items from the original compare to # in Party. 
 

 
  



Forced tip declaration 

Setup>Time and Attendance>T&A Front of the house>Options 1: “Force Declared Tips for missing out 
punch?” With this flag on, If someone doesn’t punch out the next time they go to time clock the system 
will prompt them to declare their tips. 

 

 
 

A pop up prompting for the declared tips for the day they forgot to punch out. 
 

 
 



Table determines check printer used 

Setup>Hardware>Terminal Stations>Page 1:”Chk Prtr from Table setup?” associates printers with tables, 
optionally, so you can choose per terminal if you want the table to determine what printer will be used. 
The Controlling flag in each terminal 
 

 

 
Additional setup in tables 

Setup> Restaurant Layout>Tables>Edit: “Check Printer” 

 

 
 



 
 

 

 
 
 
Change Name on Start tab 

Can now change name on start tab. By using NAME/NAME you can change the name and will now see 
the changed name at reopen and takepayment. 
 
Cashout Enhancement: 

 
Additions to “of this shift” cashout  

***Sales, tips, charge sales, charge tips block now appears on “Of this shift cashout” Previously it was 
always entire day.  This is for people cashouts only’ 
 
Server cashout enhancements  

Setup>Restaurant Miscellaneous Data>Cashouts 2:  New Flags that will eliminate certain sections from 
the server cashout. 

a. Eliminate Paidouts Summary – server cashouts 
b. Eliminate Voids Summary – server cashouts 
c. Eliminate Sales Summary – server cashouts 
d. Eliminate Discount Summary – server cashouts 

 
  



176 – No Entire Day Cashout 

This user privilege is designed for sites that are having trouble reconciling because they have servers 
who work doubles, but do cashout of “entire day” at the end of both shifts, believing that “clear totals” will 
clear at midday.  Even though they see “of this shift” they continue to touch entire day.  With this flag they 
would not be able to do a cashout for “Entire Day”. 
 
 

 
 

  



Declared Tips on Time Report 

Setup>Time and Attendance>T&A Front of the House>Options 2:”Add declared tips to time rpt?” 
 
 

 
 
 
 

 
 



Comp/Discount Detail on server cashouts 

You now have the option of printing “Comp/Discount Detail” on the server cashouts.  By selecting this 
option the cashout could be displayed and/or printed by comp/discount information, type, check number 
and dollar amount.   

Currently the comp/discount lines do not tell how many comp/discounts of a certain kind there 
were.   

New listing of certain items on server cashouts 

 A major/minor category Is needed setup  “major/minor on server cashouts”.    

 There is a new button on the server cashout options screen with the label found in setup for this 

button. 

 If selected, a new section is added  to the cashout below the closed checks listing for these items 

using the label in setup as the heading for the section Columns: 

CHK# ITEM  AMOUNT 
 

 
 

 
 



 
 
 
FOH Flash reports 
 

On the FOH Flash reports we added the ability to print the cover counts, item counts and customer 
counts on the hourly sales as well.  
 
 

 
  
  



 
New Hourly Category report 

This is a new hourly report.   For this report there is a new setting that allows defining up to 5 of the 16 
possible flash categories to be included in this report. 
 

 

 
  



On the FOH Flash reports – In the hourly sales sections (entire house and by cost center) there is a flag 
for  the ability to print by the 15 min interval as well as the existing hour and half hour selections.   
 

 
 
 

FOH operations: 
 

 
 

  



The button below is a toggle that will take you from Hourly, to Half Hourly to Quarter Hourly:  
 

 
 

 

 
 



 
 

Labor cashout employee count 

Setup> Time and Attendance> T&A Front of the house>Options 2: “Labor Cashout Employee Count?” 
Hourly Flash Report - The employee displays in the hour in which the manager clocked the employee in 
at and displays the correct # of employees.  With this on the  
 
The numbers in the last column are the numbers of employees on the clock for that hour.  There is an 
existing feature that puts these same numbers on the hourly Cashout if you turn it on. 
 

 
 
LABOR COSTS  10/17/14 17:00 

ENTIRE HOUSE 

     1234567890123456789012345678901234567890 

Old:->HR    SALES   LABOR$    HOURS  LB$/SLS 



     -> 5     0.00     0.00     0.00 -------- 

New:->HR   SALES  LABOR$  HOURS LB$/SLS  EMPL 

     -> 5    0.00    0.00   0.00    0.00 00/00 

 
 

 

BOH hourly sales report through reports and batches.   

 

Print in 15min. intervals 

Print the fields that we are currently forecasting based off of Sales, customers, checks, entrées, etc. 

BOH Settings: 
 



 
 

New optional hourly format – Sales, checks, Guests, covers 
There is a new flag for this 
HR-END    SALES      CHKS    GSTS   CVRS 

 

 
 

 

  



New Cell Types: 
Cell Type 33 – Fast Cash 

 
New cell type 33 is a button you can use on an order screen to apply cash payments to a check 
without leaving the order screen.   
 
 Price 1 in this cell can be set as follows: 

 
A positive number like 10.00 or 25.00 means $10 or $25.   Sites could have a bunch of these for 
5, 10, 20 etc. 

 

 
 
  



0.00 means next whole dollar rounded up from the check amount. 
 

 
 

-1.00 means clear. 
 

 
 
 
Examples of what it will look like from the FOH. 



 

 
 
After entering the amount this box pops up with the pertanent information. 
 

 
 

 
 
 
  



Cell Type -34 Round Up 
 

Round Up Donations 
There is a new cell type 34 “Round Up” –This is a menu item that if added to the check, rounds 
the check to the next dollar amount.   it is intended that this item be configured through gifttype to 
be excluded from sales and flipped to a payment type for the round up amount . 

 

 
  



There also needs to be an entry in Gift Cert with the same inventory number so it can subtract 
from sales. 

 

 
 
Need the form of Payment - donation  

 

a  
  



Still needs to point to the interface type Credit that is from setting it up in Giftcert. 
 

 
 

Use at the FOH.  Note that the check is $16.10 
 

 
  



When the round up donation button is hit, it rounds up the check to $17.00, with a $.90 donation. 
 

 
 

This is what like on the cashout. 
 

 
  



Sales Journal: 

 
  



Cell Type 35 - Reopen Highlight 
Check Status via Color Dots 

New positouch feature, cell type 35.  Supports  4 colored dots based on the values in price 1 of 
the cell  

Add cell type 35 – “Reopen Highlight” 
Price 1 = 0.00 None  
price 1 = 1.00 Green – 
price 1 = 2.00 Yellow – 
price 1 = 3.00 Red - 
price 1 = 4.00Magenta - =  

Put one of these items on a check and the check gets a colored dot on the reopen and take 
payment screens.  The idea is that if you have a mobile app like MyCheck etc., you can add a 
dummy item, cell 35, to the check via xml and then distinguish the status of these checks. 
 
They can help to indicate to the user the state of a check like “connected customer linked to 
check”, “connected customer payment applied” or similar states. 
 

 
 
 
 
 

 



 
 
 
  



Cell Type - 36 “0 Prc Item Copy to Sep Chks 

New cell type 36 “0 Prc Item Copy to Sep Chks”  This is an item that will be forced to have 0 price and 
when checks are separated or split, this item will be duplicated to all of the children.   
 

  
 
 
  



New User Privileges 

Setup>User Privileges codes>Assign Privileges: 
173 - Post payments to Server 

This flag is designed for Managers and Team checks. It overrides the fact that with post payments to 
server on globally, team checks do not follow post payments to servers.   With this user privilege a 
manager closing a check that is a team check, that check closing would follow post payments to servers 
even though it is a team check and normally would not. 
 
 
 

 
 
 
 
  



174-Message for XML Checks. 

XML Notify for servers 

Setup>User Privilege Codes>Assign Privileges: “174 – Message for XML Checks” New tag 
<NotifyServer> that adds a record to the slot of these notifications 

 

 
 

 
 
 



175-Allow POSiGuestPay 

 

 
 

176 – No Entire Day Cashout 

This user privilege is designed for sites that are having trouble reconciling because they have servers 
who work doubles, but do cashout of “entire day” at the end of both shifts, believing that “clear totals” will 
clear at midday.  Even though they see “of this shift” they continue to touch entire day.  With this flag they 
would not be able to do a cashout for “Entire Day”. 
 
 

 



Limit to 16 user privileges 

Setup>Restaurant Miscellaneous Data>System 1 >More: “Limit to 16 user privileges?”  Now that there 
are 24 user privileges we have a new flag that can be set if you want to limit the user privileges to 16. 
 
 

 
 
Change to exporting user privilege codes:   

 

 
 



 
 
 
 
 
Emp Type S – Select Alt Job option  

Setup>Time and Attendance>T&A Backoffice Setup>Options>More Flags: “Eliminate Employee Type: “S 
– Select alt job” This employee type can be removed from POSI Time and Attendance and is configurable 
via flag setting to add/remove as needed.  
 

 
 

 
 



TAXML enhancement 

 
TAXML.EXE with new command: 
                TAXML UPDATEEMPLCSV 
File name is UPDTEMPL.CSV. 
File format: 
EMPL#,”ALT NUM” 
e.g. 
1,”11111” 
2,”22222” 

 
 

Block negative deposits being entered.  Sales Journal.  

Setup>Payment>Sales Journal Options>Standard Options>More: “No negative deposits?” 
 

 
 

 
 

Flash Category forces cash 

Setup>Payment>Payment system options>Options : Flash Category Forces cash Manager only. 
 

 
 
 
 
 

 
  



Quantity of overring Checks: 

Setup>Hardware>Guest check options: Number of overring copies 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  



Main item modifiers sort with Main Items 
Menu Screens>Prep Printouts> Prep Printouts option 1: “Mods as Main Items sort with Main Item?” With 
this flag for prep Mods as Main items sort with their main item.  
 

 
 
 
Miscellaneous Pay exclusion from EFF. rate by job 

Setup>Time and Attendance: T&A BOH>Departments and Jobs>Edit jobs: Exclude this jobs 
miscellaneous pay from EFF. Rate Calculation 
 

 



Credit Card timeouts and Retries configurable 

 
1) Timeouts and retries by CC channel 

 
This feature allows to modify default timeouts and retries for each of 6 CC channels (you can do more 
than one channel at the same time) . To modify these values for any CC channel add to spcwin.ini into 
[SpcWin] section the following lines.  Each line is independent of another and can be added individually. 
 
Example: 
 
CC_RetriesChannel2=1 
CC_TimeoutChannel2=20 
 
The lines above will modify the number of CC retries for Channel 2 from default value of 3 times to 1 time 
and modify CC timeout for Channel 2 from default value of 180 sec to 20 sec. 
 
Note, that you also can modify default CC retries and timeouts values for all channels by using lines 
CC_Retries=<…> and CC_Timeout=<…> 
 
The number of retries means that spcwin will retry CC transaction for so many times additional to main 
attempt (this logic has not changed, just a reminder on how this works).  For example, number of 
retries=1 means that spcwin will do total of 2 attempts before declaring “No transit response” (main 
attempt and 1 retry). 
 
 
 
 
 
 
Questionnaire feature – enhancement 

Setup>Messages>Messages to People: 
We have a questionnaire feature. This is the setup screen.   Note response type 3 meaning multiple-
choice.   Note the question in the message field and the 3 responses (not setup correctly) in the response 
block. 
 

 
 

  



The result of this setup at the FOH is as follows: 
 

 
 
What we have added is the ability to support external .txt files for each of the 5 answers.   If a 
user puts &answer1.txt in setup in the responses block (any file name proceeded with &) instead 
of displaying the row, you display the contents of the text file.  The reason to use text files is to 
have longer answers, when the first answer is a text file (&), then you use a new grid called 
L_USER_MESSAGE2 and T_USER_MESSAGE2.  Which are 20 rows instead of 7.   Responses 
can now produce multiple rows in the display based on how the .txt file breaks up the rows.   So 
you can end up with this: 

 
This is the question: 
(1)-   This is the first line of the first answer 
         And it continues on another line that you indent with a few blanks 
         And then keeps going till the .txt file is exhausted 
(2)-   This is the second response and is not a .txt file 
(3)-   This is the third response and is from a .txt file 
         And also is multi line 
         It is assumed that 

 
 

 Here is how it looks at the foh after touching punch in. 
 



 
 

What we want is to be able to configure answer 1 to do what we always did when any answer 
button is touched, to go forward and finish the Punch In.   But we want to be able to configure 
answer 2 to simply collapse the popup and leave you in the step you were in before touching 
Punch In, without punching in.    

  



The primary use of this feature will be for “punch in” and “punch out”.   So for example, if I were to 
select answer 2 in the case above, I will end up here where I can decide if I really want to punch 
in or quit or do something else like select a different job.   I cannot move forward with a punch in if 
I answer 2. 

 

 
 
 
 
 

ChktoDbf enhancement 
We have added new parameter to CHKTODBF.EXE. 
                /CHK_NOS- 
                /CHK_NOE- 
These command are similar to commands below but for selecting specific check number or group of 
checks . 
If you need to populate DBF files for check number 100, the command would be: 
                CHKTODBF 01/01/15 /CHK_NOS—100 /CHK_NOE-100 
For creating DBF files for checks 1-25, the command would be: 
                CHKTODBF 01/01/15 /CHK_NOS—1 /CHK_NOE-25 
 

/TRANS_NOS – Starting transaction number 
            /TRANS_NOE – Ending transaction number 
 
 
 
  



Removal of % label when using Tip Pool Override’s 

Here is how the tip pool section of a typical Cashout looks: 
 

 
 
Cashout Reports with Tip Pool Override displays an incorrect label 

When a Cashout Report is run during a shift with Tip Pool Override defined but on a Server that 
worked in a prior shift, the labels for the tipshare % collected, is incorrect.  The labels display the 
current label and not the label of Tipshare actually collected.   

When tip pool overrides are being used we now remove the tip pool % defined in 
backoffice set up because it will not be correct most of the time.. 

 
 

  



Source 
Setup>Hardware>Terminal Station>Page 1: “Source” 
We now have the ability to capture the source of all transactions in the check data. This way we can 
determine whether a transaction was performed on a POSI Hardwired terminal, an online XML order, or 
via BOH application, as well as Wireless devices such as Skye pads and slates, table top device, ziosk, 
menupad etc. 

 

 
 
 
 
 
 
 

Item cannot be deleted 
Menu >Edit an Order Screen> cell: Item cannot be deleted?” It can be determined on item level whether 
an item can be deleted of not. 
 
 

 
 
 



Gratuities 
Gratuities on Labor Distribution and Payroll Reports 

Setup>Time and Attendance> T&A backoffice>Setup options>Show gratuities on reports? “ 
With this flag on we show gratuities on LDR and Payroll Report. and also including gratuities in overtime 
calculation. You will need to rebuild your TAF files and set the following flags: 
 

 
 
Use Gratuities in overtime calculation 
Setup>Time and Attendance> T&A backoffice>Setup options>More: “Use gratuities in overtime 
calculation?” With this flag on gratuities are included in overtime calculation. 
TAF files will need to be rebuilt after setting the following flag. 
 
 

 
 
  



Labor Distribution Report: 

 

 
 
Payroll Detail Report: 
 

 
 
 
 

 
  



Fast Food Menu Terminal assignment profiles  

New BOSETUPW.EXE and MENUW.EXE  
Setup>Restaurant Miscellaneous Data>System 1>More: “Use Fast Food Menu Terminal Assignment 
Profiles?” When this flag is on, for fast food, the fast food terminal assignment screen changes and also 
gives you a configure profiles screen. 
 

 

 
 
 
Access to New Profile Screen: 
 

 
 
 
  



By using profiles for fast food you are no longer restricted to the first 16 defined menus. You can used 
any of the 64 defined menus in up to 20 profiles.  
 

 
 
You can then set each day/shift with a profile which can consist of 1 -4 defined menus 
. 

 
 
 
 



 
 
 
 
 
 
 
Product Mix Report  

The Matrix report is a new report, shown below.  The format change allows more information on a 
single page.  The Matrix shows categories across the top of the page with information below, in 
columns.   The Matrix report allows you to track the quantity of product you go through on the 
“average” by hour, half hour and quarter hour.  In SETUP you can select how many weeks back 
you want the system to go to calculate the average. 
The second report format, Single per Page, allows printing a single category on each page. An 
example, is below.  

 

 
 

  



The Matrix Report  

 
 
 

  



Single Category per Page Report  
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Auto detection of Menu Items 

There is this setting in pmneww setup that makes the system auto detect the menu items that use an 
ingredient.   It is called auto detect menu items list.   If you select an ingredient called Patty the 
system builds the category of menu items that use a patty rather than the old way where you had to 
list burger, American burger, French burger, big mac (2 patties). 
 

 
 
This feature automatically builds the list of menu items that use the ingredient items selected in the 
CATEGORY SELECTION. If the list includes items that are not sold or available at this store, it does 
not matter, since only the items that are sold will reflect on the reports. 
 

 
 


